Browsing PAC3's section
← Back to ACE
🔁

Mirrored article

This page is synced automatically from wiki.pac3.info (last synced 11 hours ago). Edits made here will be overwritten on the next sync — contribute on the source wiki instead.

Simple .MDL: Converting Models

Simple .MDL: Converting Models

📁 TutorialUpdated 1 day ago•4 views
tutorial , model , obj , mdl , zip Simple .MDL: Converting Models This guide is mainly intended for people who want to convert their old models (usually .OBJ ) to .MDL and don't really care about

tutorial ,
model ,
obj ,
mdl ,
zip

Simple .MDL: Converting Models

This guide is mainly intended for people who want to convert their old models (usually .OBJ ) to .MDL and don't really care about the additional features so it only covers simple model creation. It assumes that you're using .OBJ files, however this method will work for any kind of model, including those with bones.

Requirements & Preparations

Before you start enable file name extensions in Windows. This is gonna help you avoid getting confused with all the different file types.

Windows 10

- In Windows Explorer go to View and check File name extensions .

Windows 11

- In Windows Explorer go to View → Show > and check File name extensions .

All required tools as well as methods of downloading and installing them are listed below.

Blender and Source Tools

Download Blender 1) and Blender Source Tools then:

- Install Blender

- Open Blender :

- Go to Edit → Preferences → Add-ons → Install

- Select the blender_source_tools file and click Install Add-on

- Make sure to check the box next to the add-on name and press Save Preferences

Crowbar and 7-Zip

Download 7-zip and Crowbar then:

- Install 7-Zip

- Unpack Crowbar using 7-Zip

- Open Crowbar and go to the Set Up Games tab

- At the bottom, in the Steam Library Folders section click Browse… and select your Steam folder 2)

Creating .MDLs

Exporting

- Open Blender and import your .OBJ model — File → Import → Wavefront (.OBJ)

- Go to the Scene panel:

- Set Export Path to the folder that you want to export the model to.

- Set Export Format to SMD

- Click Export → Collection.smd

Compiling

Download model.qc and put it in the folder where you exported the .SMD file, make sure that exported .SMD file is called Collection.smd then:

- Open Crowbar and go to the Compile tab

- Click Browse… in the QC input: line and select the model.qc file that you downloaded

- Change Output to Subfolder

- Change Game that has the model compiler to Garry's Mod

- Click Compile and wait for it to finish.

Creating a .ZIP archive

- After compiling the model in Crowbar click Goto to find the compiled model files

- If you want to convert textures and include them in your archive, now is the time → Basic Materials

- Select all the files, right click them and select 7-Zip → Add to archive…

- In the new window set Archive format to zip and Compression level to Store then click OK

- Upload the .ZIP archive → Hosting custom content online

- Use the link in the Model part

And that's it.

Additional Information

You can add materials to your model once you import it into PAC → Replacing materials/textures

More info about .MDLZIP archives → Using MDL files in PAC

Crowbar explained → Crowbar (Modding Tool) Guide

Ask for help → Official PAC Discord

1)
Tested with 2.83
2)
This should be the folder that contains the steamapps folder, for example C:\Program Files (x86)\Steam

Was this article helpful?

See More

Discussion(0)

No comments yet. Be the first to ask a question!

Have a question? Sign in to join the discussion.